Mails en HTML : images dans le corps du mail transformées en [cid:

ccciolll

Vétéran
Club MacG
Bonjour,

le sujet que j'aborde ici n'est pas très spécifique mac, mais en habitué de Macg je préfère commencer par poser la question ici.

Voilà, depuis mon mail pro (serveur exchange) quand j'envoie des mails en HTML avec des images imbriquées dedans (donc image simplement clic-glissée, que ce soit par ThunderBird ou Mail), le résultat passe bien chez certains destinataires (et notamment si je m'envoie le mail, ça passe correctement).

Mais chez d'autre, les images sont transformées en liens url du genre [cid: suivi de tout un code ]. C'est le cas par exemple si je teste un envoi vers ma messagerie perso en gmail. Et plus embêtant, c'est le cas de plusieurs clients. Ce qui fait que quand je veux envoyer un mail avec des captures d'écran pour leur expliquer un truc (EDIT, du genre, ici il faut faire ça (une image) et ensuite il faut faire ça (une autre image) etc) , ben ça ne marche pas. Un peu pénible.

J'ai fais des recherche google mais je ne tombe que sur des sujets de plus de 5 ans et qui ne parlent jamais du problème de ce que reçoit et voit le destinataire mais d'obscures façons de coder un mail en html, probablement du temps où c'était moins plug and play dnas les logiciel de messagerie.
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 306
58
St Germain en Laye - FRANCE
Certains clients mail sont parametrés par defaut pour ne pas télécharger les images des mails en html. (Pour ne pas donner au spammeurs d'indication que le mail est bien arrivé sur une adresse email valide)
C'est peut être ce qui coince chez certains destinataires de tes mails

Dans Outlook par exemple, il faut aller dans Outils puis Centre de gestion de la confidentialité, puis téléchargement automatique, et décocher la case "Ne pas télécharger les images automatiquement dans les messages html ou RsS"
 
Dernière édition:

ccciolll

Vétéran
Club MacG
Oui, c'est vrai.
Mais en l'occurrence, sur mon compte gmail, des mails de ce type venus d'ailleurs s'affichent bien, et mon e-mail pro fait partie de mes contacts donc il n'est pas « suspect » aux yeux de gmail.
J'ai l'impression que ça vient du serveur exchange ou qqchose du genre.
J'ai évidemment commencé par poser la question au responsable informatique qui gère ça, mais parfois ça met des mois à obtenir une réponse (voire parfois jamais) et si je peux trouver une autre solution plus rapidement…
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 306
58
St Germain en Laye - FRANCE

ccciolll

Vétéran
Club MacG
Bon, je n'ai probablement compris qu'une partie des choses du fait que le texte est en anglais, mais il ne semble pas y avoir de solution idéale.
Le CID va se bloquer sur certains e-mails (ceux en ligne, notamment) mais les deux autres vont activer les barrières anti-spam si j'ai bien compris.
En outre, je n'ai pas compris comment utiliser les autres méthodes. par contre, ce qui est cirieux, c'est que dans les « cons » du CID, il indiquent
  • Lots more effort
  • Harder for less technical staff to achieve
Je ne suis pas sûr du sens ? Est-ce que ça veut dire que c'est compliqué à faire ? Pour moi il n'y a rien de plus simple, je clic-glisse l'image dans le corps du mail à l'emplacement voulu.
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 306
58
St Germain en Laye - FRANCE
Pareil.... Je ne comprends pas ces 2 arguments en défaveur du CID
 

ccciolll

Vétéran
Club MacG
Bon, donc à re-creuser quand j'aurais 30 minutes devant moi (le temps, notamment, de trouver l'équivalent de cet article en Français pour réussir à appliquer les solutions alternatives)
En tout cas ça disculperait le serveur exchange.