Mise à jour de logiciels déconne

M

Membre supprimé 2

Invité
J'ai un problème avec Mise à jour de logiciels d'Apple.

Jusqu'à présent Mise à jour de logiciels fonctionnait correctement.

Mais depuis aujourd'hui, ce n'est plus le cas.
  • Quand on appelait Mise à jour de logiciels depuis les Préférences système, Mise à jour de logiciels se mettait en avant du panneau des préférences. Il reste systématiquement en dessous et son icône s'agite frénétiquement dans le Dock (en le sélectionnant, il revient normalement en avant).
  • Les logiciels à mettre à jour ne sont plus sélectionnables (je ne peux plus cocher ou décocher ce que je veux mettre à jour).
  • Les éléments des menus de Mise à jours de logiciels ne sont plus accessibles (ils sont visibles fugitivement, mais je ne peux cliquer dessus).
Impossible donc, de choisir ce que je veux télécharger et de ne télécharger uniquement ou télécharger et installer, etc.

C'est universel ou n'est ce que sur mon système (10.3.9) ?
 

Dos Jones

Va modo va molo...
Club MacG
17 Juin 2004
19 591
1 937
67
A pas de loups...
Tu n'as pas fait du ménage dans "Ordi/Biblio/Receipts" ?
 
M

Membre supprimé 2

Invité
Tu n'as pas fait du ménage dans "Ordi/Biblio/Receipts" ?
Je retire les langues inutiles à chaque installation. Comme je le fais depuis des années, ce n’est probablement pas ça.

J’ai fais un essai sur une autre session et Mise à jour de logiciels fonctionne.

J'ai effacé le fichier com.apple.SoftwareUpdate.plist des préférences générales et redémarré sur la session ordinaire. Ça fonctionne normalement maintenant.
smile.gif


Ce que je ne comprends pas, c'est que c'est le même fichier pour toutes les sessions. Sur ma session habituelle, ça déconnait et pas sur une autre. En supprimant le fichier commun, cela fonctionne de nouveau.
blink.gif


J'ai copié et comparé le contenu des com.apple.SoftwareUpdate.plist avant et après et je ne vois pas ce qui pouvait poser problème dans ce petit fichier de texte.

Le mauvais :
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>LastAttemptDate</key>
<date>2007-07-09T09:31:59Z</date>
<key>LastResultCode</key>
<integer>0</integer>
<key>LastSuccessfulDate</key>
<date>2007-07-09T09:31:59Z</date>
</dict>
</plist>

Le bon :
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>LastAttemptDate</key>
<date>2007-07-09T09:37:59Z</date>
<key>LastResultCode</key>
<integer>1</integer>
<key>LastSuccessfulDate</key>
<date>2007-07-09T09:37:59Z</date>
</dict>
</plist>
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 946
3 162
En effet, la diff&#233;rence est sur le code retour de la derni&#232;re tentative.
Un petit bug myst&#233;rieux : de recr&#233;er le fichier ex nihilo l'a peut-&#234;tre forc&#233; &#224; repasser dans un &#233;tat ad&#233;quat.