Coup de main ? Problème changement DD iBook

M

Membre supprimé 2

Invité
Bonjour à toutes/tous,

J'ai changé le DD de mon iBook (Toshiba 30GO 4200 trpm) par un Toshiba 5400rpm avec 16 mo de cache (j'avais hésité avec le 7k60 d'hitahi)

Le démontage se passe bien, je ne casse aucune pièce, je ne perds pas de vis, je change le DD, je remonte le tout.

Boot time
J'écoute le bruit du DD, il tourne, tout va bien.

Je mets le DVD d'OSX fourni dans la boîte de mon boobook
Ecran gris, puis la pomme apparaît
Lancement de l'installer

Mais avant ça, petit retour en arrière

[MODE STORY ON]
Quand je branchais le DD dans le boitier externe (2,5" USB2/FW400) sur le mac pour tester, la premiere fois ça allait bien (toute première connexion).
D'ailleurs, je ne pouvais le brancher qu'en USB2, en FW, le disque s'arretait/se
relancait sans arret (dommage pour un boot sur disque externe).
J'ai eu une demande d'initilisation, puis j'ai formaté, fait un test avec CarbonCopyCloner, nickel.

Il faut aussi savoir que j'avais après avoir testé le DD sur le mac, testé sur Windows.
Il me fallait obligatoirement 2 ports USB2 (un pour l'alim, l'autre pour la connectique) pour accéder normalement au contenu du disque (entendez: partitionnement / formatage et copie de données pour test).
J'avais créé une partitition FAT32, NTFS, puis supprimé le tout histoire d'être tranquille.

Rebranchage sur Mac, puis là ça va moins bien.

Problèmes d'alim qui me disaient (sur OSX) "Disque consomme trop, je vais le déconnecter" alors que mon iBook était branché sur secteur (a priori rien à voir, tout dépend de la tension forunie en sortie de port USB).
Alors que la première fois, pas de problèmes de ce type.
A croire que le passage sur le PC lui a détraqué la tête à ce DD.
Mais je reteste sur Mac: ça veut plus, aussi bien en USB2 qu'en FW, mais par contre sur PC, ça va, le DD marche bien.
OUIIIIINNNNNN
[MODE STORY OFF]

Retour après la fin de montage et changement de DD:
Je lance l'utilitaire disque pour formater le disque.
L'utilitaire se lance, puis gros plantage.

Aïe

La souris répond, mais plus le Mac.
J'ai un message de l'installeur qui me dit, "Erreur système, un processus vital en fond de tâche a planté", ou un message dans le genre.
Si mes souvenirs sont bons, ce mesage arrive juste avant de voir la liste des DD installés sur le système pour initialisation/paritionnement (que je ne vois pas, bien sûr, je fais là une remise en situation du déroulement normal).

D'où peut venir le problème d'après vous ?
Que me conseillez-vous de faire en l'état ?
Merci d'avance.

m4el

PS: note pour eddy, j'ai franchi le pas, mais j'aurais pas du faire voir le DD à mon PC, il l'a violenté cet imbécile de Ouinedow$
 

calvin

Membre d’élite
Club MacG
7 Janvier 2005
1 128
32
43
je comprends pas pk tu as teste ton DD sur windows...

puisqu'il est destine a ton ibook
 
M

Membre supprimé 2

Invité
Euh, oui, et alors ?

Ca va pas beaucoup m'aider ça comme réponse...
(On dirait du post pour le post, genre je fais un max de réponses qui servent à rien ;))
Et quel est le problème de l'avoir testé sur windows ? Un disque dur n'a pas de préférence.

A partir du moment où le disque marche correctement, même s'il a été mis sous windows auparavant, je tenais juste à la signaler pour que ça aide les gens à établir un diagnostic.
En général quand je vais chez le docteur, je ne fais pas juste "j'ai mal", mais je développe.

Il faudrait peut-être que je le resorte, que j'essaie avec mon ancien DD, puis que je refasse une batterie de tests sur le nouveau DD.
Ah oui, ça me revient, j'ai testé sous windows pour voir si le problème (d'alimentation ?) que je rencontrais avec la connexion FW était aussi présente en USB2 sur le PC (pas de FW sur le PC...)
 

Leehalt

Membre confirmé
17 Janvier 2004
411
22
Par là...
Tu sais quoi? je me demande si c'est pas ton boitier externe qui n'aurait pas flingué ton disque dur au point qu'il ne soit pas bien reconnu par OS X? Windows est peut-etre plus laxiste, je sais pas... En tout cas, j'ai un boitier du même genre USB2/FW qui ne fonctionnepas en FW sur le mac et qui demande une alim externe en USB2.

Sinon, tu es sûr que tu as correctement rebranché le câble du DD, comme ils sont petits et fragiles, c'est pas évident d'être sûr qu'on a bien tout correctement rebranché. Il faut un peu de force tout en étant très délicat.
 

Fogi

Membre d’élite
26 Avril 2000
1 164
134
65
Au Sud de la Côte Ouest
As-tu tenté un formatage de bas niveau avec données à zéro ?
 
M

Membre supprimé 2

Invité
Merci pour votre aide,

Je squatte également sur les forums d'autres sites mac (pour cette fois powerbook.fr)

Un gentil monsieur m'a dit avoir connu avec la même config le même problème

Il l'avait résolu en lançant le boot de Jaguar (X.2), partitionné (sans plantage cette fois), puis relancé l'install avec X.3

Je ferai le topo de la situation pour les futurs bidouilleurs qui semblent "nombreux" à réaliser cette manip', on ne sait jamais, ça pourra servir en cas de plantage identique.
Donc il me reste plein de choses à tester, mais en premier lieu tenter une install avec OSX version commerciale CD.

ありがとう
さようなら !
 

Amophis

Membre émérite
27 Avril 2004
754
18
41
Bordeaux (33)
m4el a dit:
Merci pour votre aide,

Je squatte également sur les forums d'autres sites mac (pour cette fois powerbook.fr)

Un gentil monsieur m'a dit avoir connu avec la même config le même problème

Il l'avait résolu en lançant le boot de Jaguar (X.2), partitionné (sans plantage cette fois), puis relancé l'install avec X.3

Je ferai le topo de la situation pour les futurs bidouilleurs qui semblent "nombreux" à réaliser cette manip', on ne sait jamais, ça pourra servir en cas de plantage identique.
Donc il me reste plein de choses à tester, mais en premier lieu tenter une install avec OSX version commerciale CD.

ありがとう
さようなら !

Tu as toujours le disque 30Go ? Tu as essayé de la monter dans ton boitier, de booter dessus? De faire une install dessus? Est-ce qu'il présente les même symptomes d'alim?

Pour l'alim USB, j'ai le même soucis avec mon boitier externe, à part mon Dell de mer*e au boulot, aucun ne fourni assez de jus pour l'alimenter, par contre, en FW, il démarre nickel. Le boitier est neuf ou d'occaz?

;)
 
M

Membre supprimé 2

Invité
Si j'ai le DD de 30Go, bien sûr, vu que je vais m'en servir comme petit rack d'appoint. Je comptais même m'en servir pour tester le boot sur disque externe (rien que d'y penser j'adore cette idée, raaaah vive le Mac)

Monté dans le boîtier, pas encore pu que je n'avais pas encore tout démonté
J'en suis à un stade précoce, si l'on peut dire (premier démontage puis remontage)

Je me suis déjà servi du boîtier, neuf, mais en FW, j'étais obligé d'utiliser l'alim' externe (via l'usb2) et le disque "rebootait" nonstop
Il faut comprendre par là que j'entendais clairement le bruit du moteur se lancer, puis s'arreter 2 secondes plus tard, sans arrêt
J'ai vite arrêté mes tentatives.
Est-ce qu'un disque 2,5" FW a besoin d'une alim externe pour marcher ??

Pour le boîtier, voici le lien vers le site où je l'ai acheté sur place
http://boutique.sersys.com/product_info.php?cPath=71_77&products_id=97

Boîtier fort sympa au demeurant

Pour les tests sur le 30, comme je te l'ai dit, je n'ai pas encore pu les réaliser.

Et comme toi, ça me fait chier d'avoir à utiliser une alim externe pour un DD 2,5" !
Mais je pense que le 30 ne fera pas autant d'histoires que le 80Go de ce côté-là.

Mais alors côté FW, c la bérézina ! (cf au-dessus)

Mais comme tu t'en doutes, mon problème reste celui du DD dans l'iBook, le reste, c'est presque secondaire... ;)
 

Amophis

Membre émérite
27 Avril 2004
754
18
41
Bordeaux (33)
Oui je sais que le boitier c'est secondaire, mais ça permet d'isoler le problème plutôt que de ne chercher dans un seul sens ;)

Perso avec le FW, je n'ai pas besoin d'une alim externe. De plus je choppe l'alim en USB par le port PS2 de la souris (sur le PC a mon frère par ex.)


Par contre je ne comprend pas qu'il ne marche pas en FW, il ne devrait pas y avoir de soucis de ce côté là :mouais:

enfin si tu n'arrives à rien, l'extreme c'est de remonter ton iBook avec le disque d'origine, car le 80Go à peut être un problème.


Mais je pense que tu devrais essayer aussi une "clean install" du système.

PS: pour le clonage j'avais booté sur mon disque externe de 160Go pour cloner les deux disques 2,5" et là, nickel ;)
 
M

Membre supprimé 2

Invité
Bon, je m'en suis finalement sorti

J'ai resorti le nouveau DD de l'iBook, remis dans le boîtier pour le tester sur PC et Mac.

Surement à cause d'un boitier externe un peu naze, je devais obligatoirement brancher en premier le cable d'alim, puis le cable USB2 ou FW

Obligatoirement l'alim en premier, puis l'autre cable, sinon rien du tout !
Le disque réagissait pas...
Et même le câble FW seul ne suffit pas à alimenter le boîtier, un comble !

Fort de ce constat, j'ai pu voir que le disque marchait très bien
J'en ai profité pour virer les partoches, puis recommencé l'install, et là tout s'est très bien passé
Je ne comprends pas ce qui s'est passé la première fois
Il fallait apparemment proprement éjecter le DD avant de le mettre dans l'iBook, ce que je n'avais pas fait après l'avoir testé
Donc conseil pour les futurs bidouilleurs: achetez le DD, et montez le directement ! ;)

Quant au résultat ? Plutôt... génial !
Copie de mp3 vers iTunes, de mon ancien dossier utilisateur, etc...
Tout se fait vraiment plus vite
Et je n'ai testé que quelques dizaines de minutes seulement, par manque de batterie, mais le résultat était déjà visible

Et pour les applications, j'ai vraiment l'impression (et ça ne doit pas en être une) qu'elles mettent 2 à 3 fois moins de temps à se lancer !
C'est assez bluffant !
Le bruit ?
Le DD précédent était très silencieux, celui-ci émet un très léger souffle que je n'entendais que parce j'étais dans une pièce extrêmement calme dans une maison au fin fond de la campagne Milliacoise

Tout ça pour dire que je conseille vivement à tout le monde de réaliser cette opération.
Je suis devenu un expert en démontage d'iBook, où je mets moins de 10 minutes pour démonter. ;)
Tant qu'on prend le bon matériel et qu'on observe bien la manière dont il faut opérer, on se rend compte que la conception est vraiment bien foutue et qu'il est très simple de réaliser le changement de DD / tout ce que vous voulez dans le boobook, vraiment.
Alors quand je vois des magasins come MacWay facturer 150 euros pour un changement de DD, je crie au vol...

Enfin, merci à ceux qui m'ont aidés.

Tchuss
 
  • J’aime
Réactions: Amophis

Leehalt

Membre confirmé
17 Janvier 2004
411
22
Par là...
m4el a dit:
Pour le boîtier, voici le lien vers le site où je l'ai acheté sur place
http://boutique.sersys.com/product_info.php?cPath=71_77&products_id=97

Boîtier fort sympa au demeurant
J'ai exactement le même. Et il ne fonctionne pas en FW sur Mac je confirme, même en l'alimentant en USB2 comme le vendeur m'a indiqué de le faire lorsque j'ai voulu le retourner pour remboursement. Evidemment il m'a fait la démo qu'il fonctionnait très bien en USB2 et en FW sur un...PC et je suis reparti avec mon boitier comme un con. Sur Mac, il ne fonctionne qu'en USB2 chez moi, rien en FW, et ce, que je branche l'alim avant ou après le cable FW. Malgré la belle gueule du boitier, ACHAT A DECONSEILLER AUX MACUSERS !!! :eek: :eek: :eek:
 

chupastar

Membre d’élite
Club MacG
10 Décembre 2003
2 268
231
C'est bon à savoir, parce que j'aimerais bien acheter un boitier externe avant de changer le DD de mon iBook, afin de mettre l'ancien dedans et pouvoir le recycler... J'aimerais un boitier pas cher et fonctionnant avec le FireWire.

Si quelqu'un aurait un bon lien à me donner... Merci. ;)
 
M

Membre supprimé 2

Invité
Chez moi il marche en FW, mais en branchant 1) l'alim via USB 2) le câble FW

Ce qui est tout à fait anormal, vu que le seul câble FW doit suffire à l'alimenter, donc oui, à déconseiller aux MacUsers équippés d'un iBook 12" ;)

Par contre les autres, à tester...