erreur initialisation mysql sur snow leopard server

Trouvez vous ces informations intéressantes ?

  • Oui, continue de nous tenir au courant d'usage domestique du mac mini server.

    Votes: 0 0,0%
  • Non, arrête de flooder le forum....

    Votes: 0 0,0%

  • Total voters
    0
  • Poll closed .

psykopat

Membre confirmé
18 Janvier 2008
116
7
Lyon
Bonjour,

Ne sachant où mettre ce post je le mets ici. S'il faut le déplacer n'hésitez pas à me le dire.

Je viens d'acquérir un mac mini server avec Snow Leopard Server.
J'ai pas mal joué avec mysql sous linux sans problème particulier.

J'ai tenté d'utiliser l'admin serveur pour lancer mysql. J'ai juste configuré mysql pour que les bases soient sur le 2eme disque : le démon mysqld plante, tombe en time out et boucle en essayant de se relancer.

J'ai fait une première recherche sur internet et j'ai lu que le script mysql_install_db gére mal les arborescence contenant un espace. Hors le 2eme disque du mac mini a un espace.
http://discussions.apple.com/thread.jspa?messageID=10420461
J'ai renommé le disque, modifié les réglages de tous les serveurs pour que répercuter ce renommage sur les différents services. Et j'ai tout relancé.

J'ai pu lancer manuellement mysql_install_db qui s'est exécuté sans problème (via un sudo).
Malheureusement Admin serveur continue de tenter de lancer le script qui continue de planter.
Visiblement il continue d'essayer d'utiliser l'ancien nom du disque et je ne sais pas pourquoi
Bloc de code:
100429 22:36:34 [Warning] Can't create test file /Volumes/Macintosh HD2/ServiceData/MySQL/taniguichi.lower-test
100429 22:36:34 [Warning] Can't create test file /Volumes/Macintosh HD2/ServiceData/MySQL/taniguichi.lower-test
/usr/libexec/mysqld: Can't change dir to '/Volumes/Macintosh HD2/ServiceData/MySQL/' (Errcode: 2)
100429 22:36:34 [ERROR] Aborting

100429 22:36:34 [Note] /usr/libexec/mysqld: Shutdown complete
Il est continuellement en démarrage, je n'ai pas la possibilité d'arrêter le serveur.
Lorsque je regarde dans Volume, il existe toujours une référence pour l'ancien nom du disque dur (avec des sous dossiers pour Jabber et le Web).

Du coup je ne sais pas comment :
  • arrêter les tentatives de lancements de Mysql par l'admin serveur
  • faire en sorte que mysql prenne en compte le nouveau nom du disque dur
J'en viens à me demander s'il ne faut pas réinstaller le serveur (ce qui m'obligerait à acheter un superdrive au passage) pour repartir sur une base saine et faire les renommages avant d'initialiser les serveurs.
Ca me ferait un peu mal au coeur de devoir réinstaller un SL Server, on se croirait sur Windows :siffle:
 

psykopat

Membre confirmé
18 Janvier 2008
116
7
Lyon
Je vois que ce message n'a pas inspiré de réponse.
J'en déduis soit que la question est mal posée, soit que le problème est trop spécifique.
Merci quand même à ceux qui ont pris le temps de le lire. :zen:

Du coup je vais tenter de refaire une clean install ce soir.
Et comme j'ai pas l'intention d'acheter un lecteur de DVD, je vais tenter de faire une install à partir d'une clé USB.

Suite au prochain numéro
 

psykopat

Membre confirmé
18 Janvier 2008
116
7
Lyon
Je continue d'alimenter le fil dès fois que ça puisse servir à quelqu'un plus tard.

Installation d'un mac mini server part 1 :
1) Le mac mini server n'ayant pas de lecteur DVD, je commence par dupliquer le CD d'install de mac os x server sur une clé USB. Prévoir une clé USB 8 Go.
Cela se fait sans problème avec l'utilitaire de disque.
1h plus tard la clé est prête.
2) Je reboote le mac mini server sur la clé usb. Cela fonctionne sans problème.
3) Je sélectionne mon 1er disque pour réinstaller le système : message d'erreur, OS X Server refuse de s'installer sur lui même
4) J'efface ma partition système avec l'utilitaire de disque en mode rapide. Puis je retente de sélectionner mon disque pour l'installation. Nouvel échec. L'installateur OSX Serveur reconnait encore qu'il est déjà installé sur ce disque.
5) J'avoue que trouve ça un peu bizarre, mais je tente un effacement complet. Résultat : 1h45 d'attente pour formater mes 500 Go.

J'en suis là, à suivre....
 

psykopat

Membre confirmé
18 Janvier 2008
116
7
Lyon
6) Formatage terminé, je repasse dans le menu d'installation de OS X Server. Ce coup ci j'ai une flèche verte sur le disque système que je viens de formater. Je lance l'installation et au bout d'une seconde j'ai le même message d'erreur que précédemment : installation précédente détectée. :rateau:
7) Visiblement la procédure d'install a conservé des infos en mémoire, je redémarre le mac et relance une install sur le disque système que je viens de formater. Celle ci se lance sans problème : conclusion je pense qu'un effacement rapide suffisait, il fallait juste rebooter....:mad:
8) Je suis la procédure d'install en sélectionnant que le minimum dans les services. Tout se passe bien jusqu'au moment de rentrer la clé de licence..:siffle:
9) Il refuse ma clé de licence en me disant qu'elle est déjà affectée à un autre serveur. Vu que je l'ai activé il y 'a 2 jours je me demande si le fait d'avoir réinstaller le serveur suffit à lui faire perdre le fil... Ca me parait bizarre....:mouais: En attendant je débranche le réseau, re valide ma clé qui passe cette fois ci et je peux finir l'install.
10) Après plus d'une heure de recherche sur internet je finis par avoir ma réponse :
http://support.apple.com/kb/TS2959
J'ai acheté un adaptateur USB ajoutant une prise ethernet, que je n'avais pas lors de la 1ere install. Visiblement cela pose soucis à Mac OS Server d'avoir plusieurs interface ethernet.
La solution semble être de faire la mise à jour en 10.6.3.

A suivre...

PS : Honnêtement je m'interroge sur un OS dit serveur qui plante à l'install lors de la validation de la clé de licence car incapable de gérer plusieurs interface réseaux. Autant pour mon usage perso c'est plus comique que réellement bloquant, autant dans un milieu pro c'est inacceptable :mad:
 

psykopat

Membre confirmé
18 Janvier 2008
116
7
Lyon
11) Mise à jour effectuée, le problème de licence est réglé, les 2 interfaces réseaux fonctionnent. Le serveur Mysql démarre, Apache aussi.
Du coup je tente d'installer un CMS et d'y accéder : Je n'arrive pas à utiliser comme je le veux le HD data que je n'avais pas effacé. Je tente de dupliquer les droits POSIX pour que les propriétaires & droits soient identiques sur la partie data et sur la partie système qui elle fonctionne bien.
Ca ne fonctionne pas :(
Je suppose que c'est la surcouche ACL qui a du mal à gérer le disque data qui n'a pas été formaté en même temps que le reste.

Au grand maux les grands remédes : je repars sur une install pour que mes 2 DD et mon install soient propres.
Comme je n'ai pas besoin d'un RAID 1 je tente de construire un RAID concaténé afin de ne pas avoir à gérer le remplissage de mes 2 disques.
Et hop c'est reparti pour une nouvelle installation.
 

psykopat

Membre confirmé
18 Janvier 2008
116
7
Lyon
12) Réinstallation rapide et sans problème. Mysql OK, Apache OK. Je configure le DNS à l'identique de ma dernière installation.
Et là nouveau problème : je passe par l'admin server pour créer mes zones et l'assistant essaye à tous les coups de créer une zone en NomdeMachine.NomdeDomaine. alors que j'essaye de lui faire créer une zone en NomdeDomaine. : encore une fois je trouve que la surcouche apple est peu documentée (pour le moment je n'ai pas trouvé comment débrayer cette auto complétion sur internet) et du coup on la subit au moins autant qu'elle nous aide...:siffle:
Pour le moment j'ai juste désactivé le DNS, il faut que je vérifie que l'absence de DNS (interne) n'a pas d'impact sur les autres services
A suivre
 

psykopat

Membre confirmé
18 Janvier 2008
116
7
Lyon
13) Je constate des erreurs de résolution de nom dans les logs apache. Sans conséquence apparente sur le fonctionnement d'apache.
14) J'ai pour le moment 3 usages de mon mac mini :
  • Station de téléchargement de torrent : pour l'instant j'utilise Transmission, mais visiblement il n'existe pas de mode daemon sur mac, contrairement à Linux. Mis à part ce problème tout semble fonctionner correctement
  • Serveur DNLA pour diffuser mes vidéos sur la PS3. Après avoir tester Media Link, j'ai finalement choisi Twonky Media Server. Le premier avait l'avantage de faire du transcodage à la volée. Cela fonctionne à peu prêt, mais globalement je le trouve moins réactif que twonky et surtout j'ai pas réussi à lui faire générer une liste de mes vidéos, il reparcourt tous les répertoires à chaque fois que je le sollicite. Twonky ne fait pas de transcodage mais il est fiable et réactif.
  • La dernière fonction que j'utilise en ce moment c'est l'hébergement de site web. Pour ce faire j'utilise un CMS/Blog : Wordpress. Je le trouve d'un rendu plus propre que Joomla, par contre la gestion des pages statiques nécessite l'utilisation de nombreux plugins.
Une fois que j'aurais fini de configurer ces éléments je m'attaquerais aux autres fonctions qui m'intéresse : partage d'imprimante, gestion des mises à jour pour mon parc mac, et gestion de profiles utilisateurs nomades avec gestion des synchronisations des répertoires racines.
J'ai pas fini de jouer :D