Passage à Mavericks Utilisation CPU de "WindowServer"

oorel8

Membre confirmé
19 Mars 2013
10
0
Bonjour,
J'ai toujours eu l'habitude de vérifier régulièrement l'utilisation processeur des processus via le moniteur d'activité et depuis la passage à Mavericks, un processus apparait constamment en tête de liste des plus gourmands en utilisation CPU: "Windowserver".
Sous Mountain lion celui ci utilisait une part dérisoire de mon processeur mais maintenant son utilisation est souvent aux alentours des 20% et monte parfois à 40%.
Il figure aussi paræis les plus energivores dans le nouvelle onglet énergie du moniteur d'activité.
En attendant une solution ou explication, merci d'avance!
h76y.png
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 951
3 163
C'est un peu fâcheux. Tu pourrais essayer de fermer cette session et te logger sous un autre session pour voir si tu obtiens la même occupation.
Si oui, c'est que le problème se situe dans la bibliothèque générale.
Si non, c'est que le problème se situe dans ta bibliothèque à toi.

Quoi qu'il en soit, tu peux toujours faire un redémarrage en mode sans échec, qui videra les caches, puis un redémarrage normal pour voir si ça va mieux.
 

oorel8

Membre confirmé
19 Mars 2013
10
0
Merci pour ta réponse,
J'ai donc créée une nouvelle session pour tester et j'ai obtenu les même résultat sur le moniteur d'activité ( 38 % d'utilisation processeur de "WindowServer" juste en lançant Safari).
J'ai donc fait un démarrage en mode sans échec et l'utilisation processeur de "WindowServer" était bien plus élevée ( jusqu'a 110 % ).
Après redémarrage l'occupation de ce processus reste la même qu'avant. :confused:

Mais sinon, je ne sais pas combien ce processus est censé utilisé de charge processeur et je n'ai pas d'autres mac sous la main pour comparer.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 951
3 163
Sur mon installation de Mavericks, c'est en général inférieur à 1% aussi lorsque c'est le calme plat.

Donc : il y a un problème. Peut-être serait-il intéressant de vérifier si le processus écrit des choses dans les journaux du système (on peut les parcourir avec l'utilitaire Console).
 

oorel8

Membre confirmé
19 Mars 2013
10
0
Au clame plat aussi, le pourcentage descend vers 3 ou 4 % mais c'est au moindre mouvement que le pourcentage augmente fortement, quel pourcentage obtient tu lors du déroulement d'une fenêtre dans safari par exemple? ( 40% pour moi).

Par contre je ne sais pas très bien me servir de la console, aurais-tu des indication sur la marche à suivre stp?
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 951
3 163
L'utilitaire Console permet de voir les journaux des applications et du système, à ne pas confondre avec le Terminal ;) Il se trouve dans le dossier des Utilitaires.

J'utilise peu Safari mais j'utilise Firefox, WindowServer se contente de hausser un sourcil (3%). Avec Safari, c'est un peu plus (entre 3 et 5%) et le chargement d'une page normale (MacG ;)) fait monter à 12 %.
 

garnierobin

Membre confirmé
19 Septembre 2012
49
1
Bonsoir !

J'ai le même soucis que oorel8 ! Personnellement c'est plus le Kernel Task qui prend de la mémoire et du CPU.

La conséquence est que le système "bloque" assez régulièrement. C'est insuportable.

Après beaucoup d'essais différents (SMC, clean install, autorisations, Onyx ...) aucune amélioration (le mac est légèrement plus agréable (dans l'horrible) à utiliser).

Je suis donc allé faire un tour dans la console comme vous l'avez préconisé (mais je ne m'y connais rien en informatique si "profond") et là, surprise : mdworker et kernel: sandbox répètent assez régulièrement la meme tache ! A chaque fois c'est un échec du type :
- mdworker (normal) Import : Using too many ressources after XXXX files (...).
- kernel: Sandbox: mdworker(XXXX) deny file-read-data /Applications/(...).

Il y a aussi AppleSpell qui se répète très souvent maintenant ...

Ca veut dire quoi ??
Que dois-je faire ??

Merci beaucoup :)

PS : le problème est survenu après une surchauffe, alors que Time Machine ne s'étais pas effectué depuis 10j environ. De plus, j'utilise AppCLeaner et SMCFanControl (si surchauffe en vue). Ca fait plus d'une semaine et ça commence à m'énerver très beaucoup tout rouge !!!
 

garnierobin

Membre confirmé
19 Septembre 2012
49
1
Je viens de passer dans la boutique du Premium Resseller d'à coté. Ils ont fait une petite batterie de tests hardware avec leur serveurs spéciaux et aucun problème à ce niveau.
Ils me disent de retourner les voir pour rencontrer un spécialiste dans leur centre de réparation (gratuit ;) ). Mais d'après eux c'est un bogue de Mavericks et il va falloir attendre une MAJ ! Super ...

Si ils trouvent une résolution au problème je vous tiens au courant !
 
Dernière édition: