• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

X11, Fink, XDarwin, XFree86 : kezako ?

cux221

Membre émérite
20 Avril 2002
719
1
39
MASSY
Un conseil ne pas installé KDE, déjà sous Linux c'est une des interfaces les plus lourdes que je connaisse.
 

maousse

Vétéran
Club MacG
20 Avril 2002
7 224
445
39
Paris
orbl.eu
<blockquote><font class="small">Post&eacute; &agrave; l'origine par colibri:</font><hr /> euh...j'entends mis à part développer sous X
Quel est le rapport en fait avec X11, fink et consort?
@+


[/QUOTE]Tu peux répéter la question ?

Honnêtement, j'ai pas bien compris, mais si tu veux faire du développement pour os x, tu n'as à priori pas besoin de fink, juste des outils développeur, qui comporte tout ce qui est nécessaire....
 

colibri

Membre junior
18 Décembre 2001
69
0
Yvelines
<blockquote><font class="small">Post&eacute; &agrave; l'origine par maousse:</font><hr /> Tu peux répéter la question ?

Honnêtement, j'ai pas bien compris, mais si tu veux faire du développement pour os x, tu n'as à priori pas besoin de fink, juste des outils développeur, qui comporte tout ce qui est nécessaire....


[/QUOTE]

La question dans mon premier post disait à propos du cd ADC: à quoi sert-il donc? ce fameux cd...mais ma question était imprécise d'où ma rectification...je me doute bien à quoi peut servir ADC en général mais je ne voyais pas très bien le rapport avec fink....excusez le débutant...

Maintenant grace à toi, maousse, et à tes explications j'y vois plus clair....un grand merci!
 

Jimmy MAIZEROI

Membre confirmé
26 Novembre 2001
450
0
43
Saint-Denis, 93
perso.wanadoo.fr
Bonjour tout le monde,

Eh ben, je pensais pas que vous iriez aussi loin... Vous êtes presque arrivé à me faire perdre mon latin...

J'ai bien fait de poser la question.

Il faudrait que quelqu'un explique pour l'utilisation d'un logiciel comme The Gimp ou OpenOffice, ce qu'il faut installer et comment et surtout dans quel ordre.
J'ai vu du monde à l'instar de certains intervenants ne plus pouvoir utiliser correctement ces logiciels du monde libre.

X11 ou Xfree86, XDarwin ?, et Fink ???

Merci beaucoup,

iMacalement,

Jimmy.
 

Jetsurfer

Membre confirmé
1 Février 2001
383
4
Bonjour,
hier j'ai donc installé ce qu'il fallait via le tutorial de macdepanne et macbooster.
A savoir étape 1 de macdépanne et lorsque j'ai voulu installé Fink 0.5.1 l'iMac m'a simplement dit qu'il ne voulait pas installer le package car non reconnu.
J'ai été sur macbooster qui parlait du même sujet, j'ai comme demandé téléchargé via l'ADC les 300 Mb des dev tools, puis j'ai demandé à l'iMac d'installer Fink 0.5.1 à nouveau pas de porblème tout à bien fonctionné.
Par la suite j'ai continué les installations de Commander et Launcher.
Par la suite j'ai donc installé Gimp, AbiWord et Gnumeric comme macdepanne l'indiquait, enfin je suis retourné sur macbooster pour "customiser" le menu applications de X11 afin d'avoir les applications installées dans le menu applications et non plus devoir taper des commandes...
Finalement ben tout baigne, c'est rapide maintenant je ne dis pas que je vais abandonner Elements 2 pour The Gimp mais cela fonctionne bien et j'ai appris quelque chose.
Merci à Macdepanne et macbooster pour ces infos claires ou tout le monde peut s'y retrouver et non pas comme souvent des infos que personne ne comprend sauf les "calés" dans la ligne de commande.
Maintenant c'est vrai qu'il y a pas mal d'applications disponibles via FinkCommander mais si il faut installer KDE ect. pour toutes les faire tourner cela prend pas mal de place.
De plus ce qu'il faut dire c'est que si j'ai bien tout compris, tout cela est installé dans le répertoire sw à la racine du disque et donc facile à supprimer si nécessaire.
Enfin et j'en resterai là, pour retirer une application via FinkCommander et bien c'est facile et cela semble fonctioner convenablement.
 

kamkil

Membre d’élite
Club MacG
27 Juin 2002
2 643
31
33
Some place on Earth...
www.war3macg.fr.st
J'ai suivi la même procédure que JetSurfer à savoir que j'ai téléchargé puis installer les dev tools les plus récentes complétement (6h de téléchargement quand même) puis j'ai téléchargé fink 0.5.1 sur le site officiel.
Mais tout s'arrête là: en effet quand j'ouvre le package voilà ce que j'obtient:


J'ai lu la doc (assez courte d'ailleurs) qui était avec l'installeur mais ils ne mentionnaient pas cette erreur.
Ca m'a l'air d'être un problème tout con puisque s'agissant d'autorisations. Il ne m'a bizarrement rien demandé comme mot de passe à l'ouverture du package.
[mode nrv]Las, j'ai demandé sur toubarvert comment faire et je me suis magistralement fait envoyé chié par blob:"putain kess ke t con c grave". Je suis un newbie en la matière alors je suis ptet con par ailleurs mais dans le cas présent c'était plutôt ignorant. Il me dit de lire et reste dans le flou artistique
Bref tout ça pour dire que je trouvais pas ça sympa... [/mode nrv]

 

Jimmy MAIZEROI

Membre confirmé
26 Novembre 2001
450
0
43
Saint-Denis, 93
perso.wanadoo.fr
Bonjour,

C'est encore moi, l'initiateur de ce message.
Est-ce que quelqu'un va enfin pouvoir dire à quoi servent ces applications en pédagogie Mac et comment elles s'installent et dans quelles ordres ?
Je continue de recevoir des messages de personnes qui comme moi ont envie d'en savoir plus sur ces logiciels et finalement de comprendre leur nouvelles machines (et leur nuvel OS du coup).

Est-ce qu'un X'ien peut intervenir et nous répondre à ce sujet ?

Nous lui en serons très reconnaissant,

iMacalement,

Jimmy.
 

Jetsurfer

Membre confirmé
1 Février 2001
383
4
Salut les As,

voili, voilà j'ai installé KDE, bon je dois reconnaitre que mon iMac DV/400 prend un certain temps à le charger, mais bon c'était pour me rendre compte de la "chose".

Alors pour Gimp ect. pas de problème comme mentionné dans mon précédent message je les ai toutes mises ces applications dans le menu applications /sw/bin/gimp pour Gimp et ainsi de suite, par contre pour KDE ben là je suis obligé de passer par la fenêtre du terminal et de taper startkde.

Sinon lorsque je fais comme pour les autres applications que j'essaye de mentionner kde dans mon menu applications ben j'ai droit à : Couldn't start kdeinit. Check your installation.

Cependant le tout a été téléchargé avec FinkCommander ( heureusement qu'il est là lui sinon cela serait galère) donc pourquoi d'un côté cela fonctionne pour Gimp &amp; Co
et pas pour KDE ou Gnomme vu que j'ai le même problème.
Merci d'avance pour vos lumières, et encore merci à ceux et celles qui ont fait les tutoriaux
 

kamkil

Membre d’élite
Club MacG
27 Juin 2002
2 643
31
33
Some place on Earth...
www.war3macg.fr.st
Je suis avec le terminal et j'essaye actuellement de poster
Ya des trucs pas au point par contre mais on va pas se plain Par contre j'arrive toujours pas a installer system-xfree86
Il me dit qu'il manque 4 fichiers dans /usr/X11R6/lib_______
Personne n'a rencontré cette erreur en voulant installer c
J'ai refait l'installation deux fois et même installer XFre
Si kkn peut me filer les 4 fichiers suivants ca m'arrangerai
/usr/X11R6/lib/libX11.dylib_________________________________
/usr/X11R6/lib/libXpm.dylib_________________________________
/usr/X11R6/lib/libXaw.dylib_________________________________
/usr/X11R6/include/X11/Xlib.h_______________________________
____________________________________________________________
Il me met le message suivant pour preuve:___________________
Your XFree86 installation is missing or incomplete. Please
an XFree86 release installed and retry the installation of t
package.____________________________________________________
____________________________________________________________
__

PS: Bon en fait ca a pas marché depuis lynx pour une obscure histoire de code HTML/UBB
 

kamkil

Membre d’élite
Club MacG
27 Juin 2002
2 643
31
33
Some place on Earth...
www.war3macg.fr.st
Je relance ici au lieu de faire un nouveau sujet

Voili j'ai réinstallé X11 pour la 3ème fois après avoir viré les deux dossiers et l'appli évidemment

Cependant l'installation du package system-xfree86 ne marche toujours pas

J'ai suivi toutes ces instructions pourtant...
Depuis il y a des nouvelles version bien sûr mais je pense pas que ca vienne de là. Quoiqu'il en soit j'obtien ce message sur fink commander:
Reading Package Lists...
Building Dependency Tree...
The following NEW packages will be installed:
system-xfree86
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
10 packages not fully installed or removed.
Need to get 0B/2836B of archives. After unpacking 0B will be used.
(Reading database ... 4419 files and directories currently installed.)
Unpacking system-xfree86 (from .../system-xfree86_4.2-5_darwin-powerpc.deb) ...

- found apple library
- found X plugin includes
- found /usr/X11R6/bin/xterm
- found /usr/X11R6/bin/xrdb
- found /usr/X11R6/bin/rman
- missing /usr/X11R6/lib/libX11.dylib
- missing /usr/X11R6/lib/libXpm.dylib
- missing /usr/X11R6/lib/libXaw.dylib
- missing /usr/X11R6/include/X11/Xlib.h

Your XFree86 installation is missing or incomplete. Please make sure you have
an XFree86 release installed and retry the installation of the system-xfree86
package.

The following XFree86 software is compatible with system-xfree86:

XonX (from the XFree86 Project):
http://sourceforge.net/project/showfiles.php?group_id=18034

Apple X11:
http://www.apple.com/macosx/x11/

Press a key to continue.


dpkg: error processing /sw/var/cache/apt/archives/system-xfree86_4.2-5_darwin-powerpc.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
/sw/var/cache/apt/archives/system-xfree86_4.2-5_darwin-powerpc.deb


Apparement tout va bien jusqu'à ce que il ne trouve pas certains fichiers. Je ne comprend plus rien là

Les avez-vous??

Snifff
Kkn sait?

(je vais récupérer les fichiers chez un pote mais bon, c'est du bidouillage ça...
)
 

kamkil

Membre d’élite
Club MacG
27 Juin 2002
2 643
31
33
Some place on Earth...
www.war3macg.fr.st
Récupérés!!

Maintenant ça marche mais j'aurais bien aimé savoir pourquoi ça ne marchait pas avant


Reading Package Lists...
Building Dependency Tree...
The following NEW packages will be installed:
system-xfree86
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
10 packages not fully installed or removed.
Need to get 0B/2836B of archives. After unpacking 0B will be used.
(Reading database ... 4419 files and directories currently installed.)
Unpacking system-xfree86 (from .../system-xfree86_4.2-5_darwin-powerpc.deb) ...

- found apple library
- found X plugin includes
- found /usr/X11R6/bin/xterm
- found /usr/X11R6/bin/xrdb
- found /usr/X11R6/bin/rman
- found /usr/X11R6/lib/libX11.dylib
- found /usr/X11R6/lib/libXpm.dylib
- found /usr/X11R6/lib/libXaw.dylib
- found /usr/X11R6/include/X11/Xlib.h

Valid Apple X11 detected. Thank you, have a nice day.

Setting up freetype2-shlibs (2.0.9-1) ...
Setting up system-xfree86 (4.2-5) ...
Setting up type1inst (0.6.1-3) ...
Setting up ghostscript-fonts (6.0-3) ...
Setting up libpng-shlibs (1.0.12-6) ...
Setting up ghostscript (7.04-1) ...
Setting up libjpeg-shlibs (6b-5) ...
Setting up libtiff-shlibs (3.5.7-7) ...
Setting up libxml2-shlibs (2.4.25-4) ...
Setting up lcms-shlibs (1.09-1) ...
Setting up imagemagick (5.5.1-2) ...
 

maousse

Vétéran
Club MacG
20 Avril 2002
7 224
445
39
Paris
orbl.eu
ce qui est surprenant, c'est que chez certains il y a toujours un problème, et le haut de cette page montre que la méthode est importante.....quoiqu'on en dise...
 

Jimmy MAIZEROI

Membre confirmé
26 Novembre 2001
450
0
43
Saint-Denis, 93
perso.wanadoo.fr
Bonsoir,

Si je reviens sur cet ancien post c'est que j'ai tout installé : Fink, X11 d'Apple, Fink Comander, etc...
Bien qu'a priori, tout y es, je ne peux toujours pas utiliser OpenOffice et aucun des autres softs sortis du monde libre...

Que dois-je faire ?

Merci,

iMacalement,

Jimmy.
 

Jimmy MAIZEROI

Membre confirmé
26 Novembre 2001
450
0
43
Saint-Denis, 93
perso.wanadoo.fr
Vraiment personne pour m'aider ?
Lorsque je lance l'application (le script) Start OpenOffice.org, j'ai un message d'erreur qui m'annonce "Could not find OpenOffice.org".

SVP, laissez moi découvrir le monde libre, libérez-moi ...

Merci,

iMacalement,

Jimmy
 

Telonioos

Membre émérite
11 Janvier 2002
792
5
41
www.lemasdelachouette.com
jimmy.maizeroi a dit:
Vraiment personne pour m'aider ?
Lorsque je lance l'application (le script) Start OpenOffice.org, j'ai un message d'erreur qui m'annonce "Could not find OpenOffice.org".

SVP, laissez moi découvrir le monde libre, libérez-moi ...

Merci,

iMacalement,

Jimmy
à mon avis, il doit falloir d'abord compiler les ressources de Open Office avant de vouloir lancer l'application !!!

du moins, c'est ce qu'il me semble
 

Laurent_G

Membre confirmé
28 Juin 2001
173
0
Je ne suis pas sûr que tu trouve toutes les sources bien organisées pour OSX et l'appli compilée fait 450 Mo, il doit y avoir 5 Go de src...

Tu n'aurais pas déplacé l'application ?

Si tu veux te servir de OpenOffice malgré tes pb d'install, regarde là : http://www.planamesa.com/neojava/fr/index.php
C'est une version indépendante en Java qui est encore plus lourde (donc lente )que la version X11 mais qui fonctionne bien.
 

Jimmy MAIZEROI

Membre confirmé
26 Novembre 2001
450
0
43
Saint-Denis, 93
perso.wanadoo.fr
Bonjour et merci,

Finalement, ce que j'ai fais, c'est que j'ai carrément désinstallé OpenOffice par son désinstalleur fourni pour le ré-installer et ça marche !
Maintenant, j'ai vu qu'OpenOffice se loge automatiquement dans le dossier "Applications", normal...
Mais moi j'ai ré-organisé ce dossier en sous dossier de type "Bureautique" etc... Dès que je déplace OpenOffice, plus rien lorsque je double-clique sur Start OpenOffice... mis à part le message d'erreur "Could not find OpenOffice.org" !

Il me semble que je peux lancer l'appli via ce script ou via X11.
Moi, je ne peux la lancer que via le script. Un problème de "chemin" je pense.
Où dois-je préciser le chemin pour que le script s'y retrouve pour me lancer OpenOffice dans mon sous-dossier ?
Finalement, quelque soit l'accès, script ou X11, ils se perdent tout les deux.

Merci,

iMacalement,

Jimmy.