Installation sur des Mac incompatibles Big Sur

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
38 668
5 624
Merci pour la réponse Locke, ça ne risque donc pas de flinguer le patch pour big sur !?
Non, aucun rapport ni aucun lien avec le fait de démarrer sur telle ou telle partition ou disque dur USB.
 
  • J’aime
Réactions: Lamahi

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
377
151
Nice
blog.nojo.fr
Bonjour,

pour ceux qui "aime" les GUI, la version beta (nightly) de OCLP en GUI est disponible, voir ici et chercher Nightly OpenCore Patcher (GUI)

Quelques copies d'écran:

Capture d’écran 2021-06-28 à 10.36.38.png


Capture d’écran 2021-06-28 à 10.36.57.png
 
  • J’aime
Réactions: globetribe

mat1696

Membre expert
Club MacG
15 Avril 2014
1 410
153
Bonsoir,
Premier gros problème avec OCLP sur mon iMac14,3. Je l'utilise énormément comme serveur sur le réseau, en activant le partage de fichier. Or, pour une obscure raison, il n'est plus détectable lorsqu'il est en veille (en fait dès que l'écran s'éteint). Les Préférences Système --> Economiseur d'énergie ne proposent que l'option "Réactiver lors des accès réseaux ETHERNET". Impossible de faire apparaître l'option pour le wifi... Des idées pour m'aider ? Car c'est vraiment une fonction que j'utilise énormément et ça m'embête de devoir réinstaller Mojave :/

Je vous remercie d'avance.
Capture d’écran 2021-06-30 à 01.59.02.png
 

mat1696

Membre expert
Club MacG
15 Avril 2014
1 410
153
Personne ne peut m'aider ? Est-ce que vous avez l'option Wake On Lan via wifi ("Réactiver lors des accès réseau WIFI" ou "Réactiver lors des accès réseau" tout court) ceux qui ont patché leur système ?

J'ai essayé plusieurs choses, mais je n'arrive toujours pas à activer le wake on lan via wifi.. et c'est pas trop envisageable de connecter mon Mac en ethernet vu que le routeur se trouve à l'étage inférieur, de l'autre côté de la maison...
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
377
151
Nice
blog.nojo.fr
Personne ne peut m'aider ? Est-ce que vous avez l'option Wake On Lan via wifi ("Réactiver lors des accès réseau WIFI"

Non.

ou "Réactiver lors des accès réseau" tout court) ceux qui ont patché leur système ?

Oui.

J'ai essayé plusieurs choses, mais je n'arrive toujours pas à activer le wake on lan via wifi.. et c'est pas trop envisageable de connecter mon Mac en ethernet vu que le routeur se trouve à l'étage inférieur, de l'autre côté de la maison...

Sur un iMac 27 mi 2011 avec OpenCore-Legacy-Patcher, j'ai simplement ça:

Capture d’écran 2021-06-30 à 13.29.24.png
 

mat1696

Membre expert
Club MacG
15 Avril 2014
1 410
153
Merci à vous... Donc @chafpa tu as toi aussi bien le réglage standard (sans précision WIFI ou Ethernet, ce qui veut dire que ça fonctionne sur les deux) ?

J'ai essayé de supprimer quelques fichiers de préférences, mais rien n'y fait ! Ça m'embête vraiment comme problème, car je n'ai pas envie de downgrader pour ça, mais en même temps j'utilise énormément mon iMac en tant que serveur distant auquel je me connecte même en dehors de la maison avec un VPN... Si vous avez des idées, je suis preneur...
 

chafpa

Membre expert
Club MacG
12 Décembre 2009
2 824
216
Elsass, aux pieds des Vosges
Oui, je me connecte "normalement" en Ethernet par un câble branché en permanence sur la bête mais comme mon iMac n'en fait qu'à sa tête :D, à son réveil il s'est mis en Wifi avec mon réseau Apple de la Time Capsule Airport.

J'ai un second réseau Wifi, celui de ma box SFR, qui ne me pose aucun souci si je le sélectionne. :up:
 

mat1696

Membre expert
Club MacG
15 Avril 2014
1 410
153
Okay merci pour ces précisions.
Juste pour savoir si je peux faire quelque chose de mon côté ou si c’est du côté du patcher:
Est-ce que quelqu’un possède un iMac14,3 (iMac 21,5’’, fin 2013) ? Si oui, pourrait-il checker quelle option il a pour Wake On Lan ?

J’ai aussi posé la question sur le forum Macrumors et sur le Discord, mais personne ne semble très motivé à me répondre Et je ne veux pas retourner sous Mojave
 

daffyb

-Duck Warrior-
Modérateur
Club MacG
18 Octobre 2001
13 954
1 743
Angoulême
@macomaniac pourrait peut-être jeter un oeil à la config de la mise en veille.
Tu peux déjà poster le rapport pmset
Dans la fenêtre du terminal tu lances la commande
Bloc de code:
pmset -g custom
et
Bloc de code:
pmset -g
 

mat1696

Membre expert
Club MacG
15 Avril 2014
1 410
153
Alors:
Bloc de code:
pmset -g custom
AC Power:
 Sleep On Power Button 1
 autopoweroff         1
 standbydelayhigh     86400
 autopoweroffdelay    259200
 standbydelaylow      86400
 standby              1
 ttyskeepawake        1
 hibernatemode        0
 powernap             1
 highstandbythreshold 50
 hibernatefile        /var/vm/sleepimage
 displaysleep         20
 womp                 1
 networkoversleep     0
 sleep                20
 halfdim              1
 autorestart          0
 disksleep            10

Et

Bloc de code:
pmset -g
System-wide power settings:
Currently in use:
 standby              1
 Sleep On Power Button 1
 womp                 1
 halfdim              1
 hibernatefile        /var/vm/sleepimage
 powernap             1
 autorestart          0
 networkoversleep     0
 disksleep            10
 standbydelayhigh     86400
 sleep                20 (sleep prevented by sharingd)
 autopoweroffdelay    259200
 hibernatemode        0
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         20
 highstandbythreshold 50
 standbydelaylow      86400

Si @macomaniac peut me faire profiter de son expertise... :coucou:
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 796
26 374
Forêt de Fontainebleau
Bonsoir mat

Je réagis tardivement à ton message. Ton Mac de Bureau a un paramétrage par défaut de la seule alimentation sur secteur. Voici le comportement induit par la configuration réduite à l'essentiel :

- sommeil disque (disksleep) : 10' de délai d'inactivité en session > sommeil-écran (displaysleep) : 20' > sommeil-Système (sleep) : 20'
- mode d'hibernation (hibernatemode) : 0 = maintien de la RAM sous tension pendant le sommeil-Système sans sauvegarde du contexte au fichier sleepimage du disque. C'est le paramétrage par défaut des Mac de Bureau.​
- hibernation (standby) : 24H de délai de sommeil-Système​
- sommeil profond (autopoweroff = norme européenne redondante de l'hibernation) : 72 H de délai de sommeil-Système​
- réactivation lors d'accès réseau (womp) : 1 = activée​

En résumé : après 20' (d'inactivité en session) > le Mac passe en sommeil-Système et... ne le quitte jamais sur une période de 24 H. Je suppose que c'est pendant une telle période d'une journée que tu voudrais que le Mac se réveille en cas d'accès réseau (normalement permis par l'instruction womp activée) ?
  • si c'est le cas et que ça ne fonctionne pas --> veux-tu essayer une modification du seul paramètre du sommeil-Système (sleep) qui le désactiverait ? - ainsi : le disque et l'écran entreraient en sommeil > mais pas le Système (le kernel ou moteur du Système chargé en RAM au démarrage). Tu pourrais vérifier alors si les accès réseau fonctionnent.
 

mat1696

Membre expert
Club MacG
15 Avril 2014
1 410
153
Bonjour @macomaniac (et merci) et les autres utilisateurs d’OpenCore Legacy Patcher qui pourraient être intéressés:

J’ai publié un rapport de bug sur le Github du patcher par rapport à ce problème. On m’a répondu que le Wake On Lan via wifi a été délibérément désactivé sur les machines patchées dû à un bug de Big Sur pouvant entraîner des instabilités réseau. C’est donc bien lié au patcher.

Ils sont cependant super réactifs et ont déjà implémenté une option dans la « nightly build » (version en cours de développement) 0.2.3. Je vais attendre que cette version soit publiée officiellement et tester d’activer l’option, en espérant ne pas trop subir d’instabilités…
Je reviens vers vous.
 
  • J’aime
Réactions: sergiodadi

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
377
151
Nice
blog.nojo.fr
Bonjour,

la première version (v 0.2.3) stable de OCLP avec un GUI est sortie, voir ici . Il y a donc maintenant 2 versions disponibles:
  • la version "classique" en texte : OpenCore-Patcher-TUI
  • la version "GUI" : OpenCore-Patcher-GUI

Voir les "release notes" ici

Voila quelques copies d'écran:

Capture d’écran 2021-07-12 à 10.12.01.png


Capture d’écran 2021-07-12 à 10.12.21.png


Capture d’écran 2021-07-12 à 10.12.52.png


Voila les release notes 0.2.3:

Changelog​

  • Fix more IORegistry issues
  • Implement OpenCore GUI
  • Ensure symlinks are preserved
  • Enable TeraScale 2 patches by default on all models
  • Fix NightShift support for macOS Monterey
  • Add UniversalControl support
    • Currently not enabled by Apple in macOS Monterey Beta 2/iOS 15 Beta 2
  • Add optional Wake in WLAN setting
    • Note: enabling may create network instability
  • Increment Binaries
    • OpenCore 0.7.1 release (07-05-2021)
    • FeatureUnlock 1.0.3 rolling (07-07-2021)
      • Previously known as SidecarFixup
    • Lilu 1.5.4 release (07-05-2021)
    • AppleALC 1.6.2 release
    • WhateverGreen 1.6.2 release
    • PatcherSupportPkg 0.0.13 release
  • Fix Intel HD4000 DRM Support in macOS Monterey (thanks EduCovas!)
  • Support optionally re-enabling iGPU in iMac14,x with dGPUs
  • Fix Windows scanning in OpenCore menu when Windows and macOS are stored on the same ESP
 
  • J’aime
Réactions: maxou56 et kaiy75

Lionelr34500

Membre confirmé
24 Février 2021
84
5
53
Bonjour,
Je ne comprends pas trop ce qu il faut faire avec la version GUI ? On doit faire sa cle usb avant avec l install de big sur dessus je suppose non ?

Sinon , j ai une carte AMD Radeon RX570 de 8go et quoi que je fasse j'ai toujours l ecran noir au demarrage et donc impossible de booter sur l'efi d open core...Ma carte est pourtant compatible metal.

Qelqu un peut m aider svp ?

Merci d avance

Lionel
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
377
151
Nice
blog.nojo.fr

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
377
151
Nice
blog.nojo.fr

Bonjour,

Je ne comprends pas trop ce qu il faut faire avec la version GUI ? On doit faire sa cle usb avant avec l install de big sur dessus je suppose non ?

L'utilisation est identique à la version non GUI, voir la documentation .

Sinon , j ai une carte AMD Radeon RX570 de 8go et quoi que je fasse j'ai toujours l ecran noir au demarrage et donc impossible de booter sur l'efi d open core...Ma carte est pourtant compatible metal.

Qelqu un peut m aider svp ?

Je ne connais pas les Macpro, peut-être essayer de poser la question dans Macrumors dans le thread macos-11-big-sur-on-unsupported-macs-thread ?