MacBook Pro Mac book pro bloqué au démarrage

mad-max78

Membre junior
10 Décembre 2020
18
1
30
Si j'ai bien compris le système est à 230 et le clone à 235 ?

Bloc de code:
-bash-3.2# df -H
Filesystem      Size   Used  Avail Capacity iused      ifree %iused  Mounted on
/dev/disk1s1    2.0G   1.3G   711M    65%   48375 4294918904    0%   /
devfs           203k   203k     0B   100%     686          0  100%   /dev
/dev/disk2      5.2M   5.2M     0B   100%      48 4294967231    0%   /private/var/log
/dev/disk3      524k   147k   377k    29%       6 4294967273    0%   /Volumes
/dev/disk4      524k   143k   381k    28%       5 4294967274    0%   /private/var/tmp
/dev/disk5      524k   160k   365k    31%      10 4294967269    0%   /private/var/run
/dev/disk6      524k   143k   381k    28%       2 4294967277    0%   /System/Installation
/dev/disk7      524k   311k   213k    60%      23 4294967256    0%   /private/var/db
/dev/disk8      6.3M   3.4M   2.9M    55%      63 4294967216    0%   /private/var/folders
/dev/disk9      2.1M   2.1M     0B   100%     287 4294966992    0%   /private/var/root/Library
/dev/disk11     2.1M   143k   2.0M     7%       2 4294967277    0%   /private/var/root/Library/Containers
/dev/disk12     524k   172k   352k    33%       9 4294967270    0%   /Library/Preferences
/dev/disk13     524k   164k   360k    32%       6 4294967273    0%   /Library/Preferences/SystemConfiguration
/dev/disk14     1.0M   266k   782k    26%       4 4294967275    0%   /Library/Keychains
/dev/disk15     6.3M   176k   6.1M     3%       2 4294967277    0%   /private/var/tmp/RecoveryTemp
/dev/disk16     524k   143k   381k    28%       2 4294967277    0%   /private/var/tmp/InstallerCookies
/dev/disk0s4    120G   105G    15G    88%  879917   14920719    6%   /Volumes/BOOTCAMP
/dev/disk0s2    379G   230G   149G    61% 1010621 4293956658    0%   /Volumes/Macintosh HD
/dev/disk17s2   1000   235G   764G    24% 1008791 4293958488    0%   /Volumes/Clone
-bash-3.2#
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 021
24 971
Forêt de Fontainebleau
Oui : 235 Go d'occupation pour Clone vs 230 Go pour Macintosh HD. Cet excédent de +5 Go fait partie de la routine de clonage d'un volume source corrompu. Clone est un très bon clone.

- veux-tu (ce qui constitue une espèce de bonus) => tester si Clone serait démarrable en l'état ? - il faut pour cela quelques commandes préalables jouant le rôle de "starter".​
 

mad-max78

Membre junior
10 Décembre 2020
18
1
30
Autant aller direct à l'essentiel et copier les données une fois le système purgé non ?

Je suppose qu'il faudra tout effacer, dans le même temps est-il possible d'effacer le bootcamp (plus d'utilité) ? Et de retrouver donc une fois redémarré usine la capacité de 500go full Mac ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 021
24 971
Forêt de Fontainebleau
Tu es actuellement démarré sur un OS de secours local : il relève d'une image-disque BaseSystem.dmg hébergée dans le volume auxiliaire Recovery HD. Conséquence : le volume Recovery HD du disque est monté et ne peut pas être démonté. Pour récupérer au volume Macintosh HD reformaté l'espace de la partition BOOTCAMP supprimée > alors que la partition Recovery HD fait obstacle en intercalaire => il faut (processus de coulisses automatique) que cette dernière soit clonée en queue de disque (possible) > puis que son original intercalaire soit supprimé (impossible car volume Recovery HD original monté et indémontable).

- en résumé de ce point : remets à plus tard la suppression de la partition BOOTCAMP et la récupération de son espace.​

----------

On reste alors sur le plan initial (pas de démarrage sur Clone > mais : reformatage > réinstallation > récupération). Passe la commande :
Bloc de code:
diskutil eraseVolume jhfs+ "Macintosh HD" disk0s2
  • ("Macintosh HD" avec les "") la commande reformate le volume invalide Macintosh HD (càd. remplace le système de fichiers jhfs+ corrompu d'en-tête de partition par un neuf > ce qui reforme un volume Macintosh HD valide monté en lecture et écriture).

Poste le retour.
 

mad-max78

Membre junior
10 Décembre 2020
18
1
30
J'ai relu 2 3 fois mais je t'avoue ne pas avoir tout saisi mis à part le résumé ! Hahaha

Franchement chapeau bas pour tes connaissances en la matière !!

Voici le retour :
Bloc de code:
-bash-3.2# diskutil eraseVolume jhfs+ "Macintosh HD" disk0s2
Started erase on disk0s2 Macintosh HD
Unmounting disk
Erasing
Initialized /dev/rdisk0s2 as a 353 GB case-insensitive HFS Plus volume with a 32768k journal
Mounting disk
Finished erase on disk0s2 Macintosh HD
-bash-3.2#
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 021
24 971
Forêt de Fontainebleau
Le formatage est bien passé. Finalisation du sauvetage à présent (ce qui va prendre du temps) -->

  • a) dans la fenêtre des 4 Utilitaires macOS > lance l'option : "Ré-installer macOS" --> à destination du volume Macintosh HD reformaté > ce qui va donner une installation propre.
  • b) en fin d'installation > après un redémarrage et divers paramétrages => une page te propose de récupérer des données --> coche la case : "À partir d'un Mac, d'une sauvegarde Time Machine ou d'un Disque de démarrage" > et choisis le volume Clone en "source". L'Assistant de migration va te proposer de récupérer ton compte > des applications > des réglages --> n'exclus rien et lance. S'il te propose en chemin une mise-à-jour d'iTunes --> refuse > car ça plante la migration. Une récupération par l'Assistant de migration est toujours très lente > avec un débit de copie très variable.

=> tu n'auras qu'à dire si tu as pu ré-ouvrir ta session à la fin.
 

mad-max78

Membre junior
10 Décembre 2020
18
1
30
Re Macomaniac,

Alors j'ai finalement réussi à réinstaller MacOS, aucun problème pour me connecter ensuite. J'ai voulu tester le Macbook, logique, et à peine j'ai posé mes mains sur les côtés du pad comme pour écrire que des carrés de stries violettes sont apparus et il s'est éteint (sans bip). Quand j'essaie de le rallumer la pomme apparait mais la barre ne charge même pas... il ne fait aucun signal sonore

Tu aurais une idée ?

Je n'arrive pas à passer la commande cmd+R au démarrage, je viens d'essayer
La commande est finalement passée, j'essaie de le redémarrer et de patienter en mode normal du coup | il a redémarré comme s'il sortait d'une veille, je veux bien tes conseils concernant cette situation car je sens qu'elle va se réitérer...

Nota 1 : désolé je sais pas comment effacer la réponse d'après qui fait doublon (incomplet qui plus est)

Nota 2 : aussitôt dit aussitôt je tombe sur le même problème et cette fois-ci j'ai le temps de dégainer mon téléphone donc voici la photo en PJ. J'ai lu sur d'autres sujets que ça pouvait être lié à la carte graphique ? Elle rendrait l'âme ?

Nota 3 : j'étais en train de tenter de te partager les infos du terminal diskutil car quand il s'est éteint il était en cours d'effacement du bootcamp. Du coup, dans l'utilitaire il m'affiche "Capacité : 379Go | Espace libre : 120Go" alors qu'il devrait m'afficher les 500 au lieu de 379. J'ai peur qu'il y ait un litige à ce niveau là aussi du coup...
 

Fichiers joints

  • WhatsApp Image 2020-12-13 at 00.55.17.jpeg
    WhatsApp Image 2020-12-13 at 00.55.17.jpeg
    134,2 KB · Affichages: 8
Dernière édition:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 021
24 971
Forêt de Fontainebleau
La faiblesse de ton modèle de Mac spécifique dans cette année-là est la nappe SATA : le câble plat qui relie le disque à la carte-mère. On ne compte plus les cas de défaillance. Mais je ne sais pas si c'est le problème ici.

- il faudrait sortir le HDD du Mac (facile - voir tuto iFixit) > le brancher en externe via un câble SATA <=> USB > tenter un démarrage (avec alt) sur son volume restauré. Si tout fonctionnait normalement (à part la lenteur induite par l'USB) => nappe SATA défaillante à changer (voir MacWay).​
 

mad-max78

Membre junior
10 Décembre 2020
18
1
30
Ah yes ça me dit quelque chose courant 2017 ou 18 mon mac bloquait sur le globe au démarrage et non la pomme. J'avais changé la fameuse nappe et tout re-fonctionnait correctement.
Je teste ça ce soir, je te tiens informé !
 

mad-max78

Membre junior
10 Décembre 2020
18
1
30
Yop ! Du coup je viens de tester. Le mac démarre sans problème et est un tout petit peu plus lent à cause de l'USB mais le problème persiste. J'ai remarqué qu'il survenait lorsque je posais ma main du côté gauche du pad. C'est de ce côté qu'il y une faiblesse.

Démonté c'est l'emplacement de la batterie, est-ce qu'une batterie usée sur laquelle serait appliquée une pression pourrait provoquer ceci ? (j'ai changé la batterie il y a quelques années aussi car il ne tenait plus très bien la charge)
Ou la pression se répercute sur la carte mère qui n'apprécie pas ?
 

mad-max78

Membre junior
10 Décembre 2020
18
1
30
J'ai du chercher mon tournevis à trois branches pour démonter la batterie histoire de pas tordre le connecteur et c'est fait.
Le problème persiste...

Lorsque nous avons fait toutes les démarches de vérification/formatage etc des DD il n'a jamais eu de bug et là en utilisation normale si. Peut-être que l'utilisation en mode dégradé/secours ne sollicite pas autant les composants, je ne sais pas trop quoi penser.
 

tirok

Nouveau membre
12 Janvier 2021
6
0
31
Bonjour Morphy

Si le volume intitulé Clone est disponible et vide de données > et si tu veux cloner le contenu de Macintosh HD dans Clone -->

Passe d'abord la commande :
Bloc de code:
caffeinate -dimsu &

  • qui va empêcher le Mac de dormir pendant l'opération ; elle passe sans commentaire

Passe ensuite la commande :
Bloc de code:
cp -av /Volumes/"Macintosh HD"/* /Volumes/Clone

  • mets "Macintosh HD" aves des "" ; pas d'espace entre HD" et / ; un espace entre / et /Volumes---
  • la commande clone Macintosh HD dans Clone
  • une ligne s'affiche par fichier copié
  • la copie suit l'ordre alphabétique des dossiers > sous-dossiers > fichiers

=> si tu vois un défilé de lignes démarrer à l'écran > c'est que le clonage est lancé. Attends jusqu'à l'arrêt du défilé et au retour de l'invite de commande -bash-3.2# en signal de complétion. Tu peux laisser ton Mac sans surveillance. Préviens quand tout est fini.
Bonjour, j'ai le même problème mon MBP 13 2012 reste figer a la fin du chargement au démarrage. C'est un MBP pro que j'ai recuperer sans disque dur, donc j'ai installer un ssd et j'ai tenter une nouvelle installation de Catalina. J'ai créer une clé bootable mac OS catalina, formaté en APFS la première fois et mac os étendue à la 2ème tentative mais rien a faire, après le redémarrage de l'installation il se plante a la fin du chargement et je suis obliger d'eteindre et de redèmarer en mode sans échec pour finir l'installation. D'ailleurs en mode sans échec il fonctionne correctement. Si tu pourais m'aider car la j'suis a court d'idées.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 021
24 971
Forêt de Fontainebleau
Bonjour tirok

Le modèle MacBook Pro 13" mi-2012 (spécifiquement) souffre d'une mauvaise qualité de la nappe SATA (qui relie le disque à la carte-mère). On ne compte plus les cas de défaillance de cette nappe pour ce modèle. Défaillance de la nappe SATA précipitée ou rendue manifeste => dès qu'on remplace le lent HDD rotatif d'usine (5400 tr/mn) par un SSD > à cause des débits en lecture / écriture quasiment multipliés par 10.

- aurais-tu un câble SATA <=> USB ou un boîtier SATA <=> USB qui te permettrait de brancher ton SSD en USB externe > et de vérifier si l'installation s'effectue normalement et si le Mac démarre normalement sur la distribution Catalina ? - si c'était le cas => la défaillance de la nappe SATA interne serait avérée et il te faudrait la changer.​
 

tirok

Nouveau membre
12 Janvier 2021
6
0
31
Bonjour tirok

Le modèle MacBook Pro 13" mi-2012 (spécifiquement) souffre d'une mauvaise qualité de la nappe SATA (qui relie le disque à la carte-mère). On ne compte plus les cas de défaillance de cette nappe pour ce modèle. Défaillance de la nappe SATA précipitée ou rendue manifeste => dès qu'on remplace le lent HDD rotatif d'usine (5400 tr/mn) par un SSD > à cause des débits en lecture / écriture quasiment multipliés par 10.

- aurais-tu un câble SATA <=> USB ou un boîtier SATA <=> USB qui te permettrait de brancher ton SSD en USB externe > et de vérifier si l'installation s'effectue normalement et si le Mac démarre normalement sur la distribution Catalina ? - si c'était le cas => la défaillance de la nappe SATA interne serait avérée et il te faudrait la changer.​
Bonsoir, j'ai essayer avec le Ssd en externe brancher en usb , mais rien a faire il se bloque toujours pareille avec Catalina et meme mountain lion.