Safari reste obstinément en Anglais...

benchfiddler

Membre junior
12 Octobre 2018
22
1
44
Bonsoir,
Je visite souvent ce forum pour égoïstement trouver des solutions à mes petits bugs, solutions que je trouve, d'ailleurs :) mais cette fois je me décide à créer un compte et poster car bien qu'ayant parcouru les sujets en rapport, il me reste un bug que je ne peux pas résoudre.

Histoire de la maladie :
Il y a quelques mois mon mini a été infecté par un virus qui forçait tous les navigateurs du système à utiliser un moteur de recherche vérolé (par ma faute, installation d'un faux programme de mise à jour de flash player... J'ai encore honte), j'ai pu m'en débarrasser avec MBAM et une manipulation pour supprimer un "profil" dans les préférences... Mais depuis, Safari est en Anglais.

J'ai essayé la commande defaults write com.apple.Safari AppleLanguages '(fr)' qui hélas n'a aucun effet, Safari redémarre toujours en Anglais :(

Mes paramètres "langues et région" montrent bien que le Fr est la langue principale :



La commande defaults read -g AppleLanguages retourne :



J'étais alors sous macOS 10.13, j'ai mis à jour vers 10.14 en espérant que ça réparerait Safari en même temps... Mais non, Safari reste encore et toujours en Anglais. Refaire les manipulations ci-dessus ne change toujours rien.
Tout le reste du système est bien en Français ainsi que mes autres navigateurs...
Merci d'avance...
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 279
24 238
Forêt de Fontainebleau
Bonsoir benchfiddler

Passe la commande :
Bloc de code:
defaults read com.apple.Safari AppleLanguages

  • la commande lit la valeur associée à la clé AppleLanguages > dans le fichier de préférenes de Safari de ta bibliothèque de compte

Poste le retour. Tu peux faire un coller dans une fenêtre de code (pour une présentation propre) ainsi -->
  • dans la page de ce fil de MacGé > presse le bouton http://chebmann.free.fr/jpg's chat/MacGe/InsererCodeMcGe.jpg ici :

    menu  : </> Code > par ⌘V colle dans la fenêtre Code > presse le bouton Insérer (ce procédé permet un affichage fenêtré qui économise l'espace de page en respectant la mise en forme des tableaux du «Terminal» --> d'où une plus grande lisibilité)
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 279
24 238
Forêt de Fontainebleau
La préférence bien en Français. Est-ce que tu as quitté > puis relancé Safari ? -->

  • si tu ne quittes pas le navigateur avant de le relancer > la nouvelle instruction (que tu avais inscrite toi-même) = Français > ne prend pas effet...
 

benchfiddler

Membre junior
12 Octobre 2018
22
1
44
Oui je l'ai quitté avec ⌘Q et relancé, puis j'ai même redémarré, pour être sûr... Mais j'ai toujours les menus et boutons de Safari en Anglais :( Incompréhensible !

J'avais aussi essayé de le réinitialiser en supprimant le dossier Safari de la bibliothèque, j'avais récupéré une ancienne version de l'app par une de mes sauvegardes Time Machine, app qui elle est bien en Français mais impossible de remplacer mon Safari en anglais par cette ancienne version, le système refuse de le modifier ou de l'effacer.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 279
24 238
Forêt de Fontainebleau
Incompréhensible !

  • oui : à croire que l'instruction du fichier de préférences n'est pas prise en compte > en étant surclassée par un cache.

Tu peux alors vider les caches de Safari par la méthode préconisée par le loigiciel lui-même : tu vas à sa barre de menus > Développement > Vider les caches (au milieu de la fenêre déroulante). Redémarre une fois > et reteste.
 

benchfiddler

Membre junior
12 Octobre 2018
22
1
44
Développement > Vider les caches
Tu veux dire Develop > Empty caches :(:(:(

Eh bien non hélas, après un reboot c'est toujours pareil. J'avais déjà fait cette manip également, désolé j'avais oublié de le préciser. Je l'ai donc refaite : sans succès.
Et la valeur de Applelanguages de Safari est toujours "fr"...
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 279
24 238
Forêt de Fontainebleau
Fais l'essai suivant -->

  • va à : Menu  > Préférences Système > Utilisateurs & groupes > déverrouille le cadenas > presse le bouton + pour créer un nouvel utilisateur. Définis un compte à statut Admin avec noms et mot-de-passe à ta guise.
  • cela fait > quitte ta session actuelle > et loge-toi dans la session du nouvel Admin. Lance Safari.

=> est-ce que les menus sont aussi en Anglais ou en Français ?
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 057
371
92
Bonjour,

Tu peux aussi vérifier que tu as bien les ressources en français :

Dans le Finder, Application, click droit sur Safari, Afficher le contenu du paquet, aller dans "Contents/Resources", et vérifier si le répertoire "fr.lproj" est bien présent...
 

benchfiddler

Membre junior
12 Octobre 2018
22
1
44
@macomaniac sur cette nouvelle session admin, Safari est bien en Français :)
@ntx j'ai bien le dossier fr.lproj (ainsi que tout son contenu... enfin, il n'est pas vide) dans Resources, ceci dans ma session habituelle.
 
Dernière édition:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 279
24 238
Forêt de Fontainebleau
Tu disais dans ton 1er message -->
Histoire de la maladie :
Il y a quelques mois mon mini a été infecté par un virus qui forçait tous les navigateurs du système à utiliser un moteur de recherche vérolé (par ma faute, installation d'un faux programme de mise à jour de flash player... J'ai encore honte), j'ai pu m'en débarrasser avec MBAM et une manipulation pour supprimer un "profil" dans les préférences... Mais depuis, Safari est en Anglais.

  • on peut se demander si ta session n'est pas affectée résiduellement par l'adware que tu avais installé "à l'insu de ton plein gré".

Va à cette adresse : ☞Malwarebytes☜ (clique le iien rouge) et télécharge l'installateur du logiciel anti-malwares. Lance l'installation. Veille surtout à ne pas céder aux invites de passer à une version Premium > d'activer une licence > d'upgrader et que sais-je : reste soigneusement dans la version gratuite du logiciel. Presse le bouton : "Scan now". Si à la fin de l'inspection > des adwares ont été listés --> utilise la fonction de suppression du logiciel.

=> tu n'as qu'à rendre compte de cette opération...
 

benchfiddler

Membre junior
12 Octobre 2018
22
1
44
En fait j'ai abrégé MBAM pour MalwareBytes' AntiMalware :shy: C'est lui qui m'en a débarrassé à cette époque, et depuis tous mes scans sont clean. J'en fais tous les jours, avec bien sûr la dernière version de l'app.
Le "profil" créé dans les préf système par le malware servait à forcer le choix du moteur de recherche dans les navigateurs, en y repensant il devait aussi peut-être mettre Safari en Anglais...? Etant pressé de tout réparer je n'en ai pas fait de copie.
 

brainiacO2

Nouveau membre
4 Janvier 2019
4
4
38
Bonsoir,
Je visite souvent ce forum pour égoïstement trouver des solutions à mes petits bugs, solutions que je trouve, d'ailleurs :) mais cette fois je me décide à créer un compte et poster car bien qu'ayant parcouru les sujets en rapport, il me reste un bug que je ne peux pas résoudre.

Histoire de la maladie :
Il y a quelques mois mon mini a été infecté par un virus qui forçait tous les navigateurs du système à utiliser un moteur de recherche vérolé (par ma faute, installation d'un faux programme de mise à jour de flash player... J'ai encore honte), j'ai pu m'en débarrasser avec MBAM et une manipulation pour supprimer un "profil" dans les préférences... Mais depuis, Safari est en Anglais.

J'ai essayé la commande defaults write com.apple.Safari AppleLanguages '(fr)' qui hélas n'a aucun effet, Safari redémarre toujours en Anglais :(

Mes paramètres "langues et région" montrent bien que le Fr est la langue principale :



La commande defaults read -g AppleLanguages retourne :



J'étais alors sous macOS 10.13, j'ai mis à jour vers 10.14 en espérant que ça réparerait Safari en même temps... Mais non, Safari reste encore et toujours en Anglais. Refaire les manipulations ci-dessus ne change toujours rien.
Tout le reste du système est bien en Français ainsi que mes autres navigateurs...
Merci d'avance...
bonjour ,
je viens d'avoir le même soucie sur Mojave a cause d'un malware une soit disant mis a jour de adobe flash pfff après bcp de recherche et bcp d'essai sans succès , j'ai contacter l'assistance apple qui ma fait mettre cette ligne de commande dans le terminal : defaults delete ~/Library/Containers/com.apple.Safari/Data/Library/Preferences/com.apple.Safari.plist AppleLanguages et Bing tout est rentré dans l'ordre j'espère vous avoir aidé a réglé votre problème
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
36 500
4 568
je viens d'avoir le même soucie sur Mojave a cause d'un malware une soit disant mis a jour de adobe flash pfff après bcp de recherche
Non, dans la mesure où tu n'as fait la mise à jour depuis le site officiel de chez Adobe ici... https://get.adobe.com/fr/flashplayer/ ...de plus il est devenu complètement inutile. Pourquoi en as-tu fait l'installation ? Il semblerait que lors de tes visites sur internet une page d'un site t'a proposé une mise à jour. Et là si tu suis les indications, bingo tu viens d'installer un bel adware/malware.

Par sécurité, installes et lances Malwarebytes, un clic sur Scan Now et il devrait faire le ménage. Pour éviter les PUBS intempestives tu installes uBlock Origin dans tous tes navigateurs et là tu pourras respirer. Le lien générique pour les autres navigateurs... https://www.ublock.org. Si tu as Adblock et Adblock+, tu les vires aussi, ils laissent passer volontairement de la PUB pour se rétribuer et uBlock sera bien meilleur.
 

brainiacO2

Nouveau membre
4 Janvier 2019
4
4
38
Non, dans la mesure où tu n'as fait la mise à jour depuis le site officiel de chez Adobe ici... https://get.adobe.com/fr/flashplayer/ ...de plus il est devenu complètement inutile. Pourquoi en as-tu fait l'installation ? Il semblerait que lors de tes visites sur internet une page d'un site t'a proposé une mise à jour. Et là si tu suis les indications, bingo tu viens d'installer un bel adware/malware.

Par sécurité, installes et lances Malwarebytes, un clic sur Scan Now et il devrait faire le ménage. Pour éviter les PUBS intempestives tu installes uBlock Origin dans tous tes navigateurs et là tu pourras respirer. Le lien générique pour les autres navigateurs... https://www.ublock.org. Si tu as Adblock et Adblock+, tu les vires aussi, ils laissent passer volontairement de la PUB pour se rétribuer et uBlock sera bien meilleur.
oui c'est effectivement ça
 

benchfiddler

Membre junior
12 Octobre 2018
22
1
44
bonjour ,
je viens d'avoir le même soucie sur Mojave a cause d'un malware une soit disant mis a jour de adobe flash pfff après bcp de recherche et bcp d'essai sans succès , j'ai contacter l'assistance apple qui ma fait mettre cette ligne de commande dans le terminal : defaults delete ~/Library/Containers/com.apple.Safari/Data/Library/Preferences/com.apple.Safari.plist AppleLanguages et Bing tout est rentré dans l'ordre j'espère vous avoir aidé a réglé votre problème

Ça a bien fonctionné ! Merci beaucoup, mon Safari est enfin revenu en Français :) :)

J'ai supprimé le fichier com.apple.Safari.plist en allant le chercher directement dans le Finder car la commande ne semblait pas le trouver... (Attention je crois que le "AppleLanguages" est en trop)
 
  • J’aime
Réactions: brainiacO2

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 279
24 238
Forêt de Fontainebleau
Grâce à brainiac (message #13) --> on apprend une information tout à fait curieuse :

- l'application Safari n'a pas qu'un seul fichier de préférences d'utilisateur > fichier localisé classiquement at: ~/Library/Preferences/ com.apple.Safari.plist (càd. dans le dossier-domicile de l'utilisateur connecté > Bibliothèque > Préférences > fichier com.apple.Safari. plist) ;​

- mais possède un 2è fichier de préférences d'utilisateur > fichier localisé at: ~/Library/Containers/com.apple.Safari/Data/Library/ Preferences/com.apple.Safari.plist (càd. dans le dossier-domicile de l'utilisateur connecté > Bibliothèque > Conteneurs > com.apple. Safari > Données > Préférences > com.apple.Safari.plist - j'ai francisé quelques intitulés)​

J'ai survolé ces 2 fichiers touffus en les déroulant en parallèle l'un de l'autre : il apparaît qu'il soient strictement identiques au départ (bref : des répliques l'un de l'autre). Tous les deux > dans le début de leurs écritures > comportent identiquement (normalement) le groupe de paramètres suivant :
Bloc de code:
<key>AppleLanguages</key>
    <array>
        <string>fr</string>
    </array>

  • en ce qui concerne la clé (key) : AppleLanguages > dans un tableau (array) pouvant inclure plusieurs chaînes (string) de valeurs possibles > la chaîne (string) comportant la valeur : fr (french)

C'est ce qui se passe chez moi > où Safari fonctionne en Français sans problème.

----------
 
Dernière édition:
  • J’aime
Réactions: brainiacO2

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 279
24 238
Forêt de Fontainebleau
J'ai fait alors l'expérience suivante : ayant ouvert graphiquement le fichier com.apple.Safari du dossier Containers avec TextWrangler > j'ai édité à la main la valeur fr => à en (english) et j'ai sauvegardé. Opération graphique strictement équivalente à ce qu'aurait donné la commande :
Bloc de code:
defaults write ~/Library/Containers/com.apple.Safari/Data/Library/Preferences/com.apple.Safari.plist AppleLanguages '(en)'

  • puis j'ai redémarré : à la réouverture de ma session => Safari a ses menus en Anglais. Alors même que le fichier com.apple.Safari.plist des Preferences a gardé la valeur fr pour la clé AppleLanguages.

J'ai fait l'expérience inverse : édité la valeur en => à fr pour la clé AppleLanguages du fichier des Containers. Ce qui équivaut donc strictement une commande :
Bloc de code:
defaults write ~/Library/Containers/com.apple.Safari/Data/Library/Preferences/com.apple.Safari.plist AppleLanguages '(fr)'

  • j'ai sauvegardé puis redémarré : Safari a de nouveau ses menus en Français.

----------
 
  • J’aime
Réactions: litobar71