Installation sur des Mac incompatibles Big Sur

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 784
210
Elsass, aux pieds des Vosges
Sans appuyer sur Option, j'ai brièvement un écran qui apparait quelques secondes avec 2 icônes :
  • Macintosh HD (mon Fusion Drive sur lequel est Big Sur)
  • OpenShell.efi

Je ne fais rien et l'iMac redémarre.
 
  • J’aime
Réactions: globetribe

xavax

Membre émérite
13 Octobre 2003
815
11
Je pense que ça doit être bon. J’ai lancé la mise à jour de big sur et à chaque reboot je vois furtivement l’écran avec l’efi.
 

xavax

Membre émérite
13 Octobre 2003
815
11
J’ai ceci
1425975252dec479d8014e24b2000693.jpg
 
  • J’aime
Réactions: globetribe

xavax

Membre émérite
13 Octobre 2003
815
11
Du coup. Ça a l’air ok. Je vais le laisser bosser un peu tout seul pour qu’il indexe tout car au reboot il rame un peu.

Apparemment il reprend les sauvegarde Time machine. Ça c’est cool
 

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 784
210
Elsass, aux pieds des Vosges
Time Machine m'avait fais (un peu) peur hier soir car aucune ancienne sauvegarde ne s'affichait.

Je l'ai laissé en suspension d'activité comme d'habitude et ce matin j'ai retrouvé mon historique dans TM :up:
 

macfredb

Membre junior
16 Avril 2012
16
2
Je vois que le fil avance depuis mon passage.
De plus en plus de personne tentent l'aventure c'est cool.

Pour info on peut aussi utiliser superduper pour cloner Catalina. Il est gratuit. (clonage avec effacement de la cible à chaque fois). Ce qui peut être un peu long de tout recopier à chaque clone....
J'ai réalisé ma clé avec micropatcher automator. J'ai pu faire une clean install de bigSur sur un disque dur externe USB. Une fois que j'ai pu vérifier que tout fonctionnait bien, j'ai fait l'installation (mise à jour, pas d'effacement) de Catalina (version patché avec dosdue1 patcher) afin de conserver mes app, réglage et utilisateurs. Et tout fonctionne bien.
 

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 784
210
Elsass, aux pieds des Vosges
Question :

- Sur un SSD externe, j'ai un clone, fait par CCC, de Big Sur avec OpenCore Legacy Patcher.

Peut-on installer ce clone sur un HDD vierge d'un autre iMac, HDD formaté en APFS Guid, sachant que l'iMac d'origine est en Fusion Drive et l'iMac cible, non ?
 
Dernière édition par un modérateur:

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
330
137
Nice
blog.nojo.fr
Bonjour,

Après avoir testé micropatcher (l'original), micropatcher (modifié par Ausdauersportler), automator (modifié par Ausdauersportler), je me lance à mon tour dans OpenCore-Legacy-Patcher :)

OCLP c'est super :)

J'ai 2 SSD internes sur mon iMac mi 2011 (avec une carte graphique compatible metal):
  • un SSD sous Catalina (c'est encore mon disque "quotidien" de travail) avec boot "Catalina Loader" sur une carte SD
  • un SSD dédié aux tests BigSur
La méthode :
  • formatage d'une clef USB en GUID
  • téléchargement de la dernière version de Big Sur avec gibMacOS
  • création de l'installer avec la commande classique /Applications/Install\ macOS\ Big\ Sur.app/Contents/Resources/createinstallmedia --volume /Volumes/ma-clef-usb
  • je télécharge la dernière version (0.0.22) de OCLP
  • je lance la configuration, l'iMac est bien détecté (12,2) , la seule modification à faire pour ma configuration est de préciser que la CG est une carte metal (Force iMacMetal Card) et son type (AMD pour moi):
Capture d’écran 2021-04-17 à 18.51.17.png


Capture d’écran 2021-04-17 à 18.50.52.png
- construction et installation de l'OC sur la clef USB (1 puis 2 ) :

Capture d’écran 2021-04-17 à 18.54.46.png
- on redémarre sur la clef USB et j'ai bien le menu du "boot picker' :

IMG_7645.jpeg

  • on choisit "install macOS Big Sur"
  • on fait l'installation classique (assez long et plusieurs reboots)
  • j'ai lu dans MacRumors que l'on pouvait installer et patcher avec OCLP, même sur un Big Sur déjà patché avec micropatcher, c'est ce que j'ai fait et je n'ai pas eu de problème
  • une fois l'installation terminée, j'ai bien la version du SMC et la version du firmware "spoofées", ce qui prouve qu'on a bien démarré avec OC :)
SMC et firmware.jpeg
- la version de l'iMac est bien "spoofée" en iMacPro1,1, on ne le voit pas ici, mais on le voit dans la configuration de OC :

Spoofed Model.png

- l'accélération matérielle est bien activée :

CG metal.png
- voila les disques en détail :
Disques.png

- je vais attendre la sortie de Big Sur 11.3 pour voir si les mises à jour OTA fonctionnent bien, c'est une des raisons principales de passer à OCLP :)

- comme actuellement mon OS "quotidien" est encore Catalina :
  • si je veux booter sous Catalina, j'enlève simplement la clef USB OC et le boot s'effectue avec le Catalina Loader (carte SD)
  • si je veux booter sous Big Sur, je remets la clef USB OC et, même avec la carte SD Catalina Loader, le boot s'effectue bien en Big Sur. Je pense que le firmware essaye d'abord les périphériques USB avant les périphériques SD.
Je n'ai jamais fait de reset de la NVRAM et cela semble fonctionner sans problème.

Pour info, Ausdauersportler, laisse tomber ses patchers et participe maintenant à OCLP, particulièrement pour les iMacs 2009-2011 :)
 
Dernière édition par un modérateur:
  • J’aime
Réactions: globetribe

globetribe

Membre junior
12 Décembre 2020
66
12
41
- comme actuellement mon OS "quotidien" est encore Catalina:
  • si je veux booter sous Catalina, j'enlève simplement la clef USB OC et le boot s'effectue avec le Catalina Loader (carte SD)
  • si je veux booter sous Big Sur, je remets la clef USB OC et, même avec la carte SD Catalina Loader, le boot s'effectue bien en Big Sur. Je pense que le firmware essaye d'abord les périphériques USB avant les périphériques SD.

Je n'ai jamais fait de reset de la NVRAM et cela semble fonctionner sans problème.

Pour info, Ausdauersportler, laisse tomber ses patchers et participe maintenant à OCLP, particulièrement pour les iMacs 2009-2011 :)

:up: Top

Pour info, de mon côté j'ai essayé le PRAM reset quand j'ai fait l'update et ça m'a tout cassé... mais je crois connaitre la raison, à savoir les deux systèmes dans le même conteneur de mon disque interne SSD... ça c'est fini en ouvrant la bête pour pouvoir débrancher le SSD interne pour booter sur la clé... ça m'apprendre à pas suivre à la lettre les consignes :zen:

Sinon, grosse nouvelle la dernière version d'OCLP supporte désormais les legacy GPU. Le résultat est apparemment encore loin d'être à la hauteur en terme de performance graphique mais ça vaut le coup d'être noté. A ce rythme, j'imagine que les développeurs arriveront à contourner Metal d'ici quelques semaines :cool:
 
  • J’aime
Réactions: sergiodadi

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 784
210
Elsass, aux pieds des Vosges
- je vais attendre la sortie de Big Sur 11.3 pour voir si les mises à jour OTA fonctionnent bien , c'est une des raisons principales de passer à OCLP :)
Aucune raison qu'elles ne fonctionnent pas. Comme déjà écrit, la version 11.3 Bêta m'a été proposée et je l'ai installée. :)
 
  • J’aime
Réactions: sergiodadi

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
330
137
Nice
blog.nojo.fr
Aucune raison qu'elles ne fonctionnent pas. Comme déjà écrit, la version 11.3 Bêta m'a été proposée et je l'ai installée. :)

J'ai vu, pas de problème :), je ne doute pas d'OCLP, c'est surtout pour être certain de ma configuration ;)

:up: Top

Pour info, de mon côté j'ai essayé le PRAM reset quand j'ai fait l'update et ça m'a tout cassé... mais je crois connaitre la raison, à savoir les deux systèmes dans le même conteneur de mon disque interne SSD... ça c'est fini en ouvrant la bête pour pouvoir débrancher le SSD interne pour booter sur la clé... ça m'apprendre à pas suivre à la lettre les consignes

C'est pour cela que je préfère personnellement garder OCLP sur une clef USB ou une carte SD, ça peut éviter des démontages et remontages ;)

Pour éviter les problèmes sur un disque interne, il est recommandé de garder un (petit) OS de secours qui se trouve :
  • soit sur un petit disque dédié et qui est le premier à être choisi (en disk0 donc)
  • soit sur la première partition d'un disque interne , la deuxième pouvant recevoir OC

"Having Opencore on a normal partition on main drive, but not the first one, is safe for AMD and NVIDIA users.
Having Opencore on any partition on a secondary drive, is safe too.
In these cases, after a PRAM reset, the iMac will default boot on main EFI partition or first partition of the main drive, places where Opencore isn't present.
NVIDIA users will then have a native Apple bootscreen ( if vbios permits it). AMD users will have a black screen during EFI boot and display will show when MacOS take control."
 

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
330
137
Nice
blog.nojo.fr
Question :

- Sur un SSD externe, j'ai un clone, fait par CCC, de Big Sur avec OpenCore Legacy Patcher.

Peut-on installer ce clone sur un HDD vierge d'un autre iMac, HDD formaté en APFS Guid, sachant que l'iMac d'origine est en Fusion Drive et l'iMac cible, non ?

Je n'ai pas trop d'idée sur cette question et surtout sur la réponse ;) . Il y a aussi à voir: est-ce que l'autre iMac est exactement le même modèle que l'iMac cloné ? OCLP prépare l'EFI pour un modèle donné de mac.

Ceci dit, si le clone est sur un disque externe , tu peux booter avec l'autre iMac, à mon avis, il n'y a aucun risque pour le disque actuel interne, au pire, ça ne boote pas ...
 

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 784
210
Elsass, aux pieds des Vosges
Je n'ai pas trop d'idée sur cette question et surtout sur la réponse ;) . Il y a aussi à voir : est-ce que l'autre iMac est exactement le même modèle que l'iMac cloné ? OCLP prépare l'EFI pour un modèle donné de Mac.
En fait, ce serait le même iMac. J'envisage de faire changer son Fusion Drive actuel (HDD 1 To + Barrette SSD 128 Go) par un SSD interne Samsung EVO 870 1 To. ;)

PS : Sur l'un de mes clones qui est un SSD externe Samsung T5 500 Go, clone fait par CCC, la notion de Fusion Drive n'apparait pas :
Capture d’écran 2021-04-18 à 18.43.44.png
 
Dernière édition par un modérateur:

sergiodadi

Membre confirmé
Club MacG
15 Janvier 2011
330
137
Nice
blog.nojo.fr
Sinon, grosse nouvelle la dernière version d'OCLP supporte désormais les legacy GPU. Le résultat est apparemment encore loin d'être à la hauteur en terme de performance graphique mais ça vaut le coup d'être noté. À ce rythme, j'imagine que les développeurs arriveront à contourner Metal d'ici quelques semaines

De plus, les auteurs commencent à envisager une interface graphique plus conviviale, cela facilitera la diffusion de OCLP , il y a déjà des études du design :)

Capture d’écran 2021-04-18 à 10.44.38.png Capture d’écran 2021-04-18 à 10.45.00.png
Capture d’écran 2021-04-18 à 10.45.08.png Capture d’écran 2021-04-18 à 10.45.13.png
 
Dernière édition par un modérateur:
  • J’aime
Réactions: globetribe

Nouvoul

Membre d’élite
Club MacG
4 Mars 2005
3 539
391
113
Bonjour les patchés !
J'avais patché mon iMac late 2012 en janvier, depuis ça fonctionnait très bien, mais il y a quelques jours (une semaine ±), quand j'allume la bête, mon réseau wifi (livebox) ne se connecte plus illico, parfois je dois attendre 1mn, voire désactiver le wifi puis le réactiver, au bout de quelques secondes/1 mn le réseau est enfin actif, mais je n'ai que 2 indicateurs allumés (barre de menu wifi) au lieu de 3 en général sous Catalina. Ce comportement nouveau serait-il une séquelle du patch, si oui comment y remédier ? Si je démarre sur Catalina pas de souci, donc ça ne vient pas du matériel.
Onyx pourrait-il être d'un bon secours, et alors quels réglages choisir ?
Merci de votre aide.
(edit: en lisant le message précédent je vois que chafpa est en 11.3, alors que moi en 11.2.3; j'ai raté une màj ?)